Scheduled for 20/05, 2025 at 18 – 21
Affects
Drift DSM Business Central
Under maintenance from 6:00 PM to 9:00 PM
Completed
20/05, 2025 at 21Completed
20/05, 2025 at 21Maintenance has completed successfully
In progress
20/05, 2025 at 18In progress
20/05, 2025 at 18Maintenance is now in progress
Planned
20/05, 2025 at 18We will be performing a software update for DSM Business Central on Tuesday, May 20, 2025 between 8:00 PM and 11:00 PM.
You are not allowed to work in the system during this time.
You can find the release description for DSM 9 already now by logging in to jmaforum.dk
If needed, our support is available by phone at 8711 0000 from 8:00 a.m. Wednesday, May 21, 2025.
In English :
We are planning a program update for DSM Business Central Tuesday, May 20 at 20.00-23.00.
You cannot work in the system during this time.
For more information on the new features and improvements, visit jmaforum.dk
If you have any questions or need assistance, please contact our support team.